#rt-thread not ready for primetime

Hmm. There was some exciting news announced that RT-Thread now compiles for the Raspberry Pi Pico. I never uses RT-Thread before, but I was intrigued by the prospect of a real-time cross-platform interface for the Pico.

So I downloaded rt-thread from github, which was a monster download. I went to the Pico directory, and managed to compile and install a blinky sketch. Success!

I was excited to see that it support for STM32 blue pill. I tried compiling that. Failure! It gave a warning about “redefinition of ‘union sigval’ in signal.h. So there seems to be a conflict with the newlib library.

Then I tried compiling the f411 nucleo board. Same problem. That is after I changed the hard-coded EXEC command in rtconfig.py from r’C:\Users\XXYYZZ’ to r’/usr/bin’.

Hmmm, lot of hard-coding there.

How about the for Raspberry Pi 2? This time I had to change

EXEC_PATH = r’/opt/gcc-arm-none-eabi-5_4-2016q3/bin’

to

EXEC_PATH = r’/usr/bin’

So much hard-coding! I also had the same compilation errors.

RT-Thread also has an “ENV” project. I downloaded that. It appeared to be some kind of configuration environment. It wasn’t clear what it was supposed to do or how it was supposed to work. They did have a bundled-up tag for it, so I downloaded that. That turned out to be a monster 90MB in size. When I unpacked it, it contained their IDE which was for Windows only.

According to their website, the Env scripts are for Linux/MacOS. And?

Their homepage is is pretty slick, and it certainly looks encouraging, but the actual engineering of the project itself is a bit “ish”. This is despite the fact that the project was started in 2006.

Upshot: I can’t be bothered wading through all the minute details to get this thing running. If you’re looking for an RTOS for your MCU, then start somewhere else.

The only silver lining in all this is that I’ve decided to revisit my “crunky” library OS for my Raspberry Pi 0. Although hardly perfect it does do a wide range of stuff like UART, SPI, I2C, SD Cards (mostly), and even display output. I doubt I will ever get USB working, though. So I was a little disillusioned with it, but now I’m thinking of dusting it off again and seeing how it compares with microcontrollers.

I want to do a lot of audio work, maybe abandon the idea of using it as a kind of “retrocomputer”, and getting some serious DSP in. So, meh, I’ll see how it goes.

I just heard about RTEMS, which seems to have support for Raspberry Pi, and a couple of STM32’s. No RP2040, though. Might worth a little sniff later, though.

About mcturra2000

Computer programmer living in Scotland.
This entry was posted in Uncategorized. Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google photo

You are commenting using your Google account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

Connecting to %s